From bigfug
Jump to: navigation, search

Running Fugio on OS X needs some third party libraries that cannot be automatically installed. This is either due to licensing issues, which prevent me from distributing the binaries, or the complex way that OS X links to libraries on different versions of the operating system.

Minimum Requirements

Fugio requires OS X version 10.9 (Mavericks) or higher

You should be able to install Fugio on 10.7 (Lion) and 10.8 (Mountain Lion) by compiling it from source.

10.6 (Snow Leopard) and earlier are not supported.

Additional Software

You will need to install:

XCode can be a big download!

Homebrew Packages

To enable running all of the plugins, wou will need to install the following packages by copying and pasting the following lines into a terminal:

brew install lua

Development Packages

If you want to compile Fugio from source on OS X, you will need the following additional packages, which are not required when just running from the binary installer.

brew install fftw
brew install portaudio

Future Plugins

These packages are not required yet, as they are for future plugins, but here is the list for reference

brew tap homebrew/science
brew tap homebrew/versions
brew install opencv3 --with-contrib
brew install assimp
brew install portmidi
brew install ffmpeg
brew install snappy
brew install libusb
brew install glew
brew install glfw3