From bigfug
Jump to: navigation, search

PaintingWithLight-Overview.jpg

Website: http://pwl.bigfug.com

What does Painting With Light do?

Painting With Light works like a paint program, along the lines of Adobe Photoshop, Paint.NET, GIMP and many others, but it differs in one very important and unique way:

You can paint with video and other animated elements

While not required, it is designed to be used with a digital video projector – to paint light onto real physical objects, creating amazing light shows and cutting edge art installations and performances, which is a process known as Video Mapping or Projection Mapping

Used without a projector, it can be used to create video paintings that can be shared to YouTube, Facebook, etc

Installation

Painting With Light is available for Microsoft Windows and Apple OSX

Download Painting With Light

HINT: Try the latest beta version first, which has the very latest features

A Linux version is in development but it is not available yet.

Windows Installation

1. Open the ZIP archive by double-clicking on it

If the archive doesn't open, you'll need to install an application such as WinZip

2. Double-click on the installer application and follow the steps in the wizard

OSX Installation

1. Open the DMG archive by double-clicking on it

2. Drag the Painting With Light icon to your Applications folder (or your Desktop, if you prefer)

Quick Start Information

To try the software out, you can use Painting With Light on a single screen, without a video projector.

You can draw on the Output Window or the Work Area but it is recommended to get used to working on the Work Area as when you are outputting to a video projector, it will save you moving your mouse to the other screen.

Drawing With Video

Mapping Textures

Tutorials

Masking Tutorial

Controlling With Duration

Toolbars

Painting With Light has two toolbars:

Accessing Windows

The main functionality of Painting With Light has been grouped together into various windows.

You can open and close these windows by going to the Window Menu

Other Topics

What are the best Video Formats to use?

External control using MIDI and OSC

Loading and Saving

Loading and saving your painting is only available once you have a license.

You can clear your current painting using File Menu -> New

You can save your painting using File Menu -> Save Painting As…

You can load your painting using File Menu -> Load Painting…

You can save an image of your painting using File Menu -> Save Image…

Frequently Asked Questions (FAQs)

You can make the Output Window go full screen (or stop being full screen) by pressing your Alt + Enter keys or using Output Menu -> Full Screen

By default, the Work Area does not draw the painting (it only appears in the Output Window). You can change this by selecting Edit Menu -> Options… -> Rendering -> Render to Work Area and then restarting the application.

Troubleshooting

While every effort is made to make sure Painting With Light is a stable application, different computers with various graphics cards means that incompatibilities can occur.

On Windows, if Painting With Light crashes, it will ask you if you want to send in a crash report - PLEASE do this as it's the fastest way for a problem to be fixed

On OSX, a crash report will pop up - copy the text and send it to mailto:pwl-bugs@bigfug.com

If you find other bugs, please send details to mailto:pwl-bugs@bigfug.com